Takeoff Degradation

Incident Report for INNERGY

Resolved

Incident resolved
Posted Jul 22, 2025 - 21:19 UTC

Monitoring

Our team was able to identify and solve this issue, takeoff budget calculations have returned to normal. We will continue to monitor the situation.
Posted Jul 22, 2025 - 15:04 UTC

Update

We are continuing to investigate this issue.
Posted Jul 22, 2025 - 14:56 UTC

Investigating

We are aware of general slowness and delays in product calculations. The INNERGY team is hard at work identifying the cause of slowness in the Takeoff application and improving the stability of the app. We will provide regular updates here in the Status Page.
Posted Jul 22, 2025 - 14:56 UTC
This incident affected: USA, Canada and Mexico (Takeoff).